> charset="iso-8859-1"
> Hi,
> I have a problem with getting ZDiscussion working the way I want it to.
> First a little background, so it becomes easier for me to explain what I
> want to do:
> On my site I have several users (called "artists") that I have built a
> ZClass for. This Artist-ZClass contains a propertysheet with the properties
> of the artist, it also subclasses ObjectManager, so the artists can add
> their own pictures in their own object.
> This works excellent, and I am about to take the next step - adding a
> discussion forum on each artist, so people can discuss the artist's work
> directly on his pages.
> I then tried to add a ZDiscussion Topic ("discuss") in the ZClass. (I also
> regenerated the methods before proceeding, to get the default interface.)
> When I tried to access the discussion at:
> http://my.host/artists/testartist/discuss
> Zope asks me for a login, and not even the superuser can access it.
> Either my thinking is screwed up (it often is ;), or it is impossible to
> accomplish this with ZDiscussions. Could anyone offer me some insight as to
> what I'm doing wrong here?

Do you have anonymous access turned off? (I.E. do you need a password
to view anything?)  If you cancel the request, do you get a traceback
pointing to something in the TreeTag file? If so, you may need to
allow anonymous users to access content information for the

I don't understand why this should be the case, and I couldn't
debug it because I couldn't figure out what validate did.

-- cary

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to