Richard Moon wrote:
> 
> I've just installed Zope 2.1.6 and PostgreSQL 7.02 and now I get a broken
> ZPyGreSQLDA with the following
> 
> Traceback (innermost last):
>    File "/opt/Zope-2.1.6-linux2-x86/lib/python/OFS/Application.py", line
...
>      import _pg, regex, sys, types
> ImportError: No module named _pg
> 
> I can import _pg from the python command line.
> 
> I still have a Zope 2.1.4 installed and that works fine with PostgreSQL
> 7.02, though I haven't tried re-installing it.
> 
> (Running on Linux 2.1 with PostgreSQL binary RPMs if thats any help).
> 
> Any clues as to the problem ?
>

You probably have a Zope installation with its own python.

try copying _pgmodule.so to lib/python1.5/lib-dynload under that zope's home.

---------------
Hannu

_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to