On Sun, Jun 18, 2000 at 01:28:26PM -0400, Tres Seaver wrote:

> Matt Behrens <[EMAIL PROTECTED]> wrote:
> > No matter what I do, I can't seem to make a ZClass a subobject of
> > another ZClass. I'm really not sure what I'm missing. Here's what
> > I've done:


> There are a couple of items in play here:
>  * Nested ZClasses are *always* addable in their containing ZClass,
>    so they don't show up as options in the Subobjects tab.

OK, cool.  That makes sense.

>  * If you have *exactly one* nested ZClass in a container ZClass,
>    *and* you have not specified any "outside" objects as addable
>    on the Subobjects tab, then the only objects which will be
>    addable in the container ZClass are instances of the nested one;
>    in this case, the management interface does not display a
>    dropdown list, but only the "Add" button (try clicking Add on
>    your Whiteboard object's Contents tab).

What was throwing me here is that when I'd hit the ``Add'' button,
I'd get ``Resource not found''.  After mumbling on #zope for awhile,
I finally went digging though the mailing list archives and discovered
an issue dating at least back to September 1999 indicating that you
had to go into the inner ZClass's factory and hit ``Change'' to
make it work.  I did this and it worked.  Collector #1334 has


> Patches gratefully accepted :)

When I discovered that what I was seeing was a bug, that was the
first thing I tried to do -- find the problem and fix it -- but at
this point, I'm too green yet to figure it out.  Maybe in the future.


Matt Behrens <[EMAIL PROTECTED]>
Student of Zope Zen
Owner/Administrator, zigg.com

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to