> -----Original Message-----
> From: Rik Hoekstra [mailto:[EMAIL PROTECTED]]
> Sent: Monday, June 19, 2000 6:23 AM
> To: Ron Bickers
> Cc: [EMAIL PROTECTED]
> Subject: Re: [Zope] Problem with adding items to ZClass instance

> Hm, this is getting hard to answer. Adding normal instances of ZCLasses
> to other ZClasses should work. Are you adding everything straight from
> the management interface or programmatically from DTML?
> If from the management interface, are you sure you always add TinyTable
> etc from within the instance?
> If programmatically, could you send the code?
>
> Perhaps you could try and adding one of the problem products in another
> way (from a dtml method instead of the management interface or the other
> way around).

The items I'm adding aren't other ZClasses, but rather from python products.
I haven't come up with an exhaustive list of which items cause the problem
and which don't, but I know at least the TinyTable and ZMySQL DB Connection
do, and the DTML Methods/Documents, MailHost and UserFolders don't.

Everything is being added via the interface.  I haven't tried adding them
via DTML.  I've never done that because I haven't had a use for it, so I'm
not sure I know how.

I setup a series of screen shots to demonstrate exactly what's happening.
Take a look at http://www.logicetc.com/Test/zclass_problem if you're
interested.

Thanks!
_______________________

Ron Bickers
Logic Etc, Inc.
[EMAIL PROTECTED]


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to