I got Apache+mod_ssl+OpenSSL working, and I just threw it into the mix.  I
have two virtual hosts, one HTTP on port 80 and one SSL on port 443.  Both
do nothing but ProxyPass to the same http:// address on port 9080.  I don't
know if I like that solution, though.

This solution "looks" secure, but I'm not so sure.  It's a secure connection
between the client and the server, and, since Zope and Apache are on the
same machine, there's no insecure communication over our LAN.  However, if I
happen to have a hacker running a packet sniffer on my server, I'm screwed.

Any comments on this?  I may just have to go the hard way and do
Apache+fastcgi...?

--- In [EMAIL PROTECTED], Wayne Izatt <[EMAIL PROTECTED]> wrote:
> I've just managed to get ZServer running behind Apache with SiteAccess
> (thanks for the how-to, anser!)
>
> Now, has anyone managed to configure SSL into a mix like this? Seems to
> me I should be able to go through the standard SSL setup for Apache, and
> not worry too much more abou the ZServer component of the architecture.
>
> thanks
>
> Wayne
>
>
> _______________________________________________
> Zope maillist  -  [EMAIL PROTECTED]
> http://lists.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
>  http://lists.zope.org/mailman/listinfo/zope-announce
>  http://lists.zope.org/mailman/listinfo/zope-dev )


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to