I'm having difficulty starting Zope. 

  Zope: 2.1.6, compiled from source with "python wo_pcgi.py"
  Python: 1.5.2, (#2, Jan 17 2000)  [GCC] on freebsd2
          Python is compiled with pthreads enabled. 
  FreeBSD: 2.2.8 (yes, I know it is outdated).

Problem Description: The compilation process seems to go just fine,
with no errors reported. When I invoke the "start" script, I get the
following output:

2000-06-23T19:42:58 PROBLEM(100) ZServer Computing default hostname
2000-06-23T19:43:19 PROBLEM(100) ZServer Computing default hostname
2000-06-23T19:43:40 PROBLEM(100) ZServer Computing default hostname
2000-06-23T19:44:01 PROBLEM(100) ZServer Computing default hostname

.... continues

I've read that this PROBLEM(100) is no big deal, and that the Zope
server eventually starts on most installations. Unfortunately with my
installation, the server never starts, I cannot resolve
and with each iteration, python dumps core. I don't know if it helps,
but 'gdb -c python.core' returns the following:

Core was generated by `python'.
Program terminated with signal 10, Bus error.
#0  0x2ef23 in ?? ()

What I've tried: (1) I changed the permissions on the various Zope
subdirectories (e.g., id= root, nobody, lorenmc) so that Zope can
write to files, but this seems to have no effect; (2) Reviewed
./var/Z2.log, but it is empty; (3) I ran through "z2.py" line-by-line
and noticed that python exits when it reaches the portion of the
script that calls the "zdaemon.run" function, which seems to be a
function that forks processes. 

Has anyone had this problem? Any advice besides "upgrade to a newer
version of FreeBSD or switch to Linux?"



Loren McCarter
Graduate Student, Behavioral Neuroscience
UC Berkeley

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to