Green things,

I've had a site in development (almost ready to deploy) and in testing for 
some time.  I just went to go through another test run, when a previously 
working page suddenly generated the following error:

Error Type: OperationalError
Error Value: (1017, "Can't find file:
'./service/return.frm' (errno: 13)")

<traceback at end of e-mail>

I looked at the traceback, and it appeared to be coming from a particular SQL 
method.  I tried testing the method, same problem.  I tried another SQL 
method.  Same again.

Ok, so I looked into it further, and checked a previous install.  I can't 
find ANY *.frm files in either zope tree.

The only event to day which occurred which might have possibly corrupted 
files was when i had to reset due to Netscape (eternal be their pain) chewed 
up all my memory (AGAIN!) and I had to resort to power cycling the computer, 
since it still hadn't responded to my 'kill this annoyingly stupid app' 
keystrokes by the time i'd got back from lunch.

However, on bootup, the fsck did not find any problems on the disc, so I felt 
reasonably safe.

Any ideas?  PLEASE?


  RedHat 6.1
  Zope 2.1.6 (from src)

Have a better one,

Traceback (innermost last):
  File /usr/local/Zope-2.1.6-src/lib/python/ZPublisher/, line 214, 
in publish_module
  File /usr/local/Zope-2.1.6-src/lib/python/ZPublisher/, line 179, 
in publish
  File /usr/local/Zope-2.1.6-src/lib/python/Zope/, line 202, in 
    (Object: sqlGetRADetails)
  File /usr/local/Zope-2.1.6-src/lib/python/ZPublisher/, line 165, 
in publish
  File /usr/local/Zope-2.1.6-src/lib/python/ZPublisher/, line 160, 
in mapply
    (Object: manage_test)
  File /usr/local/Zope-2.1.6-src/lib/python/ZPublisher/, line 102, 
in call_object
    (Object: manage_test)
  File /usr/local/Zope-2.1.6-src/lib/python/Shared/DC/ZRDB/, line 331, 
in manage_test
    (Object: sqlGetRADetails)
  File /usr/local/Zope-2.1.6-src/lib/python/Shared/DC/ZRDB/, line 312, 
in manage_test
    (Object: sqlGetRADetails)
  File /usr/local/Zope-2.1.6-src/lib/python/Shared/DC/ZRDB/, line 430, 
in __call__
    (Object: sqlGetRADetails)
  File /usr/local/Zope-2.1.6-src/lib/python/Products/ZMySQLDA/, line 
173, in query
OperationalError: (see above)

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to