Using the instructions at on
how to run multiple zopes with the same install, I semi-successfully have
two instances of 2.2b3 running.  However, when I run them, I get the
following traceback for XMLDocument (INSTANCE_HOME is /home/zopdev/zope in
this case):

2000-07-01T04:37:22 ERROR(200) Zope Couldn't install XMLDocument
Traceback (innermost last):
  File /usr/local/zope-2.2b3/lib/python/OFS/, line 467, in
    (Object: ApplicationDefaultPermissions)
    (Info: XMLDocument)
  File /home/zopedev/zope/Products/XMLDocument/, line 102, in
  File /usr/local/zope-2.2b3/lib/python/App/, line 110, in
IOError: [Errno 2] No such file or directory:

It's not looking in the right place for the image file in XMLDocument. You
can see that if found the XMLDocument product in INSTANCE_HOME/Products (of
course, or it wouldn't have tried to install it in the first place).

I get other IOErrors when I try to add or manipulate objects where Zope is
looking in the wrong place for dtml files or whatever.  Everything works as
far as I can tell when browsing the site itself.

Is this a bug, or do I need to set some other variable, or what?


Ron Bickers
Logic Etc, Inc.

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to