Brian Lloyd <[EMAIL PROTECTED]> writes:

> > On Zope 2.1.6 if you you pack the database with '0' in the days box
> > and then pack it again with '1' in the days box bad things happen. In
> > our case the first pack resulted in a Data.fs of 17MBytes (not bad
> > from a started point of nearly 2GBytes) the second pack (which I
> > assumed would do nothing) resulted in a Data.fs of 3MBytes. Great I
> > thought, however it also broke most of my site. Some of the symptoms
> > are:
> > 
> > Accessing existing folders gives KeyError
> > Many of my ZClasses are turned into DTML Methods (that is the icon
> > next to them in the folder view is a DTML Method icon)
> > All the instances of the broken classes are broken.
> > 
> >  
> > Thankfully I kept backups before performing the packs.
> 
> Richard - 
> 
> A notice was sent out to the list a week or so ago on this - 
> there is a bug in the packing machinery that (as you found) 
> doesn't correctly handle things when you pack to certain time 
> and then subsequently pack to an earlier time. The fix for 
> this is already checked in for 2.2.
> 
> Brian Lloyd        [EMAIL PROTECTED]
> Software Engineer  540.371.6909              
> Digital Creations  http://www.digicool.com 
> 
>

Brian

You have my apology I did not spot the this notice.

I shall move to 2.2 just as soon as it is out of Beta testing.

Richard

_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to