I am using Zope 2.1.6 and Squishdot 0.4.1
Squishdot works greate and works the way as I want.  However, I cannot edit the permission setting for a squishdot site.

Whenever I try to change something I got AttributeError and the Error value is

So I tried to change the permission for individal roles, they works except the acquire permission setting part.  Here I got the same error again.

These are the error code I got form the page,
Traceback (innermost last):
  File C:\PROGRA~1\APACEWEB\lib\python\ZPublisher\Publish.py, line 214, in publish_module
  File C:\PROGRA~1\APACEWEB\lib\python\ZPublisher\Publish.py, line 179, in publish
  File C:\PROGRA~1\APACEWEB\lib\python\Zope\__init__.py, line 202, in zpublisher_exception_hook
    (Object: ElementWithAttributes)
  File C:\PROGRA~1\APACEWEB\lib\python\ZPublisher\Publish.py, line 165, in publish
  File C:\PROGRA~1\APACEWEB\lib\python\ZPublisher\mapply.py, line 160, in mapply
    (Object: manage_acquiredPermissions)
  File C:\PROGRA~1\APACEWEB\lib\python\ZPublisher\Publish.py, line 102, in call_object
    (Object: manage_acquiredPermissions)
  File C:\PROGRA~1\APACEWEB\lib\python\AccessControl\Role.py, line 193, in manage_acquiredPermissions
    (Object: ElementWithAttributes)
  File C:\PROGRA~1\APACEWEB\lib\python\AccessControl\Permission.py, line 171, in setRoles
AttributeError: (see above)


so, I look inside the setRoles function, it seems, 'self.data' contain the name 'managemanage_editForm' which cause the error, am I right here?  I also look through the __init__() for squishdot, I couldn't see how it pass the 'data' passes to Permisson object when it first instance.

Where should I look for to fix this 'managemanage_editForm' problems?


Reply via email to