I've started looking into Zope to build our future sites and from what I've 
seen, I love it. I have installed Zope 2.1.6 and 2.2.0b3 for my tests, 
running on a RedHat 6.2 server (Apache with pcgi).

I had a few problems / questions I wasn't able to find an answer for in the 
various documents I looked at. So here is a somewhat long list.

I came across a little problem that you will most certainly be able to 
solve. Basically, I've tried to follow step by step the Job Board howto 
(http://www.zope.org/Members/mukhsein/job_board_howto) to get familiar 
with  the ZCatalog and the ZClasses. Everything works fine with Zope 2.1.6, 
but I am unable to have it work under Zope 2.2.0b3. I am always getting a 
standard authorization dialog box. And none of the users I defined in my 
/acl_users object work. I've seen that Zope 2.2.0 brought many changes on 
the security and ownership part. I am certain my problem is somewhere in 
there, but I am unable to find where ;-) One more comment. On the 2.2.0b3 
server, Anonymous isn't allowed to see anything except /index_html page and 
once logged in (users get a particular local role), you have the same 
rights as you normally have with Anonymous. I didn't change anything on the 
2.1.6 server. I hope this isn't the source of my problem. I've seen in this 
mailing list that there is a bug related to manage_addProduct... will 
2.2.0b4 correct my problem?

This brings me to another question. I've added a ZCatalog object in the 
2.2.0b3 Zope test server. When I go under "Indexes" and wish to delete one 
of the indexes, I get the following error message (I've cut the long path 
to make it more readable):

Traceback (innermost last):
   File [...]/lib/python/ZPublisher/Publish.py, line 222, in publish_module
   File [...]/lib/python/ZPublisher/Publish.py, line 187, in publish
   File [...]/lib/python/Zope/__init__.py, line 221, in 
     (Object: ElementWithAttributes)
   File [...]/lib/python/ZPublisher/Publish.py, line 171, in publish
   File [...]/lib/python/ZPublisher/mapply.py, line 160, in mapply
     (Object: manage_delIndexes)
   File [...]/lib/python/ZPublisher/Publish.py, line 112, in call_object
     (Object: manage_delIndexes)
   File [...]/lib/python/Products/ZCatalog/ZCatalog.py, line 369, in 
     (Object: ElementWithAttributes)
   File [...]/lib/python/Products/ZCatalog/Catalog.py, line 333, in delIndex
No Index: (see above)

This works with 2.1.6, so I believe it is a bug, or is it a "feature"?

About authorization, on the 2.2.0b3 server, I have redefined 
/standard_error_message (send an email, other layout, ...). It works fine 
except with I get the "Unauthorized" message. In that case, after canceling 
the dialog box for example, I get the error message available in <dtml-var 
error_message> displayed instead of mailed to me. I've checked that every 
object used in this standard_error_message method is available to Anonymous 
(View + Use mailhost services + Access contents information), but it still 
does not work. Any hint?

One last question ;-) I've seen in this mailing list that Squishdot will 
not work with Zope 2.2.0 until version 0.4.4... when is this version 
planed? I've tried to install Squisdot on the Zope 2.2.0b3 server and I get 
the same problem as with my "Job_Board" test... will one solution solve the 

Thank you very much for your help.

Best regards,

Gérard Métrailler Jr.

Meeting Maker Inc.
... the intelligent choice for collaborative scheduling

Web: http://www.meetingmaker.com

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to