While trying to install PoPy, I've screwed up my Zope install.  I had
trouble with my ld.so.conf and ld.so.cache files, but seem to have fixed
that.  Everything else appears to be running correctly, except Zope.

Here are the errors I get when I try to start Zope:
[root@frankenstein ewalstad]# /usr/local/Zope/start &
[1] 1161
[root@frankenstein ewalstad]# Traceback (innermost last):
  File "/usr/local/Zope/z2.py", line 493, in ?
    logger_object=lg)
  File "/usr/local/Zope/ZServer/medusa/http_server.py", line 552, in
__init__
    self.bind ((ip, port))
  File "/usr/local/Zope/ZServer/medusa/asyncore.py", line 205, in bind
    return self.socket.bind (addr)
socket.error: (98, 'Address already in use')

Here's what's using port 8080:
[root@frankenstein Zope]# fuser -v 8080/tcp

                     USER        PID ACCESS COMMAND
8080/tcp             root       2104 f....  xps

So, I tried running Zope on port 9080 and received the same "socket.error:
(98, 'Address already in use')" error.

Next, I tried to rerun the "python w_pcgi.py" thinking that maybe this would
restore any screwed up library references.  I saw the same "socket.error:
(98, 'Address already in use')" error scroll by as it ran the w_pcgi.py
script.

My question is, what happened and how do I fix it?

Any help is greatly appreciated.

Eric.


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to