My understanding was that DC decided not to fix it, but instead concentrate
on the 2.2 series.  There are some patches floating around in the archives,
but none of them worked 100% for me.  I just gave up and am running 2.2b4.
The 2.2 betas has been plenty stable for me.  Even with the few problems
with the ealy betas, it has always run without blowing up.

I *think*, depending on the authentication circumstances and location of the
ZSQL methods, you might be able to rename the arguments that they use such
that there is no conflict from acquisition (e.g., rename 'id' to 'myid' or
whatever).  That is, make sure the arguments are unique names.  That turned
out to be a big pain, but it worked.  I had other problems with
authentication that I could never find a workaround.  That's why I just went
to 2.2.

Good luck. ;-)

Ron Bickers
Logic Etc, Inc.

> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of The
> Sanfords
> Sent: Thursday, July 13, 2000 2:38 AM
> Subject: [Zope] 2.1.6 and ZSQL methods
> Like an idiot I blythly ignored all the emails flying back
> and forth concerning the problems with 2.1.6 and ZSQL
> methods because I was not using 2.1.6 and didn't plan on
> upgrading my 2.1.4 until the 2.2 was stable. Hah!!!
> Was the issue ever resolved?
> I really need for my 2.1.4 ZSQL methods to work in 2.1.6.
> Does anyone know of a patch or other workarounds?

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to