I am using Zope on a PC running on NT and using ODBC to connect to a
Informix database. I am running a query that returns a column of
INTERVAL type, calculated by subtracting to DATE types.

The query, when tested using the test tab, displays the results as I
expected. However, when I try to display the results using either a
search interface, or my own DTML method, NETSCAPE 4.7 refuses to display
the results. Instead it reckons it cannot handle the resultant HTML from
the DTML used to produce the results page. Instead, it decides the best
thing to do is save the file but when it is reloaded it load just fine.
IE5 does get a little further and it will display the page but there are
numerous strange characters at the end of the expected interval field.

This seems like some additional characters are coming back from the
query and they may cause Netscape to trip up and IE5 to display odd

What I have tried to do, without sucess, is to get access to the DTML,
within Zope, which produces the results of a test on an SQL query. This
is where the solution lives!, but I plain just can't find it.

I have tried formating the the INTERVAL type and truncating but nothing
yields the same results as the 'test' DTML.

Any ideas for a poor Zope newbie.



Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to