I thought I'd forward (with Tone's consent) an exchange
that happened off list. We've been having problems in Bristol
with Zope 2.1.6 dying under Solaris 7. (Sorry - no hard info
about this, no obvious pattern.)

The consensus seems to be that things appear to better with 
Zope 2.2 - does anyone else's experience support this?


--- Begin Forwarded Message ---
Date: Tue, 1 Aug 2000 09:49:22 +0100
From: Tony McDonald <[EMAIL PROTECTED]>
Subject: Re: Stability probs on Solaris? (Was: [Zope] Trouble 
installing on          Solaris (fwd))
Sender: Tony McDonald <[EMAIL PROTECTED]>
To: Paul Browning <[EMAIL PROTECTED]>, 
Reply-To: Tony McDonald <[EMAIL PROTECTED]>
Message-ID: <v04220884b5ac3db62b7b@[]>

At 7:07 am +0100 1/8/00, Paul Browning wrote:
>I know Tony McDonald in Newcastle has complained about
>how slow Zope is on a Sun Enterprise box up there (running
>3 times as slow as on his desktop iMac as I recall ...)
>but I don't recall him reporting stability problems. I've
>copied this to Tone.

It's weird - the python 'pystones' benchmark runs half as fast as my 
iMac, but Reportlab (an *excellent* PDF library in Python) runs like 
lightning on our Sun iron.

Our servers are all pretty stable here now. We've upgraded a box to 
Solaris 8 and I've compiled (from src) Zope 2.2.0 on it and it's 
working fine. In fact, I'm using the INSTANCE_HOME, PYTHON_HOME 
environment variables to point to *one* installation of 2.2.0 and 
have 5-6 servers running from that. Very nice.

>After playing with Zope on NT for a while, I decided it was time to try
>it on Solaris. I have duly downloaded the file, followed the
>installation instructions for the precompiled binary version, but when
>I run ./install I get get the following error:
>Compiling python modules
>ld.so.1: /work3/cultivate-eu/Zope-2.1.6-solaris-2.6-sparc/bin/python:
>fatal: relocation error: file
>/work3/cultivate-eu/Zope-2.1.6-solaris-2.6-sparc/bin/python: symbol
>fseeko: referenced symbol not found

What I do is
% python w_pcgi.py
% python wo_pcgi.py

and this does seem to work - of course, this implies a working Pyton 
setup from src.

I've never tried the ./install script (in fact, I don't think I've 
ever seen it!)

I do know that the LD_LIBRARY_PATH env variable is critical if you're 
using shared libraries (eg MySQL, LDAP etc). My variable is
% printenv  LD_LIBRARY_PATH

(note the mysql library path too...)

Dr Tony McDonald,  FMCC, Networked Learning Environments Project 
The Medical School, Newcastle University Tel: +44 191 222 5888
Fingerprint: 3450 876D FA41 B926 D3DD  F8C3 F2D0 C3B9 8B38 18A2

--- End Forwarded Message ---

 The Library, Tyndall Avenue, Univ. of Bristol, Bristol, BS8 1TJ, UK
     E-mail: [EMAIL PROTECTED]  URL: http://www.bris.ac.uk/

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to