> > > Exactly what message are you getting now?
> > 
> > I'm still getting the same error: At the python interactive prompt, the command 
>import PoPy results in the following: ImportError: 
>/usr/lib/python1.5/site-packages/PoPymodule.so: undefined symbol: PQfsize
> > 
> > Any additional help would be greatly appreciated.
> > 
> > - Steve
> > > > 
> > > > There is no reference to libpq.so, and I still receive the same error with 
>import PoPy. I question if I need a libpq.o listing from ldconfig -v or not?
> > > > 
> > > > Thanks for your prompt replies and help. I really appreciate it.
> > 
> Hokay..
> go to /opt/pgsql/libs and execute
> strings libpq.so.2.1 | fgrep PQfsize
> On my system this returns
> PQfsize
> PQfsize
> If it returns similar on your system, then 
> 1) ld is still not finding the library.  This may perhaps be
> modified by rechecking ld.so.conf and rerunning ldconfig;
> or you can edit the start script of zope and insert something like
> export LD_LIBRARY_PATH=/opt/pgsql/lib
> or, if not, 2)
> The pgsql library is badly compiled.  (get an update, or install
> your own postgres)

Okay, this is really starting to get to me.

strings libpq.so.2.1 |grep PQfsize

I checked ld.so.conf and reran ldconfig. I looks as though it knows where the 
libraries are. No luck.

I did an export LD_LIBRARY_PATH=/opt/pgsql/lib
export shows that it was recognized. Still No luck.

The PostgreSQL install was compiled from the 7.0.2 source. I'm beginning to think the 
problem is in the PoPy source - ZPyGreSQLDA works just fine, and I think it's using 
the same libraries.

I just downloaded the ZPoPy-1.3.3 tarball - still no luck yet, post to follow.

Thanks again for all of your help, and if you can thnk of anything else...

- Steve

Get your Private, Anti-Spam, Free Email at http://e3mil.com 
and Step into a Friendly Universe!

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to