> hi all
> has anybody successfully used Client.py that ships with Zope-2.2.0?  i
> can't
> seem to run it.  even on the command line.  i've searched the mailing
> list,
> but to no avail

> this is what i did:
> python Client.py http://www.zope.org

> and here's the traceback.
> Traceback (innermost last):
>   File "Client.py", line 639, in ?
>     main()
>   File "Client.py", line 632, in main
>     headers, body = apply(f,(),kw)
>   File "Client.py", line 221, in __call__
>     raise NotAvailable, RemoteException(
> bci.NotAvailable: argument 1: expected read-only character buffer, tuple
> found (File: http://www.zope.org Line:
> [])
> None None for None

> what did i do wrong?  can i use Client.py from Zope-2.1.x?


I guess Client.py or one of the libs it uses is somewhat broken. 
I get the exact same error when trying to use utilities/load_site.py 
from 2.2.0 (and Oleg  Broytmann already sent a mail with the same 
problem to this list). 
load_site from 2.1.6 works fine though, perhaps that means you can use
Client.py from 2.1.6.


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to