Darran Edmundson wrote:
> 
> I'm almost at my wit's end (again).
> 
> I have several very simple ZClasses (*none* of which
> are subclassed from CatalogAware).  The "Basic" tab
> shows them all to be subclassed from "ZObject,
> ZObjectManager".  Recently I posted asking how to
> implement copy/paste programatically.  It turns out
> this was somewhat premature - I can't even get this
> to work via the management interface, all of my
> ZClass instances reporting that "object X doesn't
> support this operation".  One of my ZClasses doesn't
> even allow renaming, throwing the same error as above.
> In all other respects the classes work as expected.


Does the traceback mention CatalogAware? i have the same problem. I have ZClass 
objects that are _not_ in any way,
shape, or form associated w/CatalogAware, and they are unrenameable, and complain in 
the traceback about CatalogAware


I tried an object inheriting from DataSkin, and a plain-jane one. Nada.

--
Do not meddle in the affairs of sysadmins, for they are easy to annoy,
and have the root password.

_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to