call :
<dtml-in "ShowProduct(product_id=1)">

with <let> you just define a variable in the current namespace

Philipp Auersperg (zwork)

*********** REPLY SEPARATOR  ***********

On 13.08.2000 at 17:27 Indra Gunawan wrote:

>Hello All
>here's the problem
>my Zope 2.2.0 is running on win98
>my Database is a MySQL
>
>I created a ZSQL method named ShowProduct with parameter product_id
>
>the template as follows : select * from products where <sqltest product_id
>type=string>
>
>why can't I call the ZSQL method directly (without using the GET/POST
>variables)?
>I try to call it like this
>
><dtml-let product_id="1">
><dtml-in ShowProduct>
>...(i would like to insert some of programs here if this is working)
>
></dtml-in>
></dtml-let>
>
>it always returns error like this
>    Error Type: Bad Request
>    Error Value: ['product_id']
>
>can anyone help please? is there any workaround for this?
>TIA
>
>-IGUN-
>ICQ:1474584
>
>
>
>
>_______________________________________________
>Zope maillist  -  [EMAIL PROTECTED]
>http://lists.zope.org/mailman/listinfo/zope
>**   No cross posts or HTML encoding!  **
>(Related lists - 
> http://lists.zope.org/mailman/listinfo/zope-announce
> http://lists.zope.org/mailman/listinfo/zope-dev )




_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to