I developed my project on Zope 2.1.6 on NT environment.
Last week i installed Zope 2.2.0 on Solaris 8.
i transferred my project to 'new' Zope.

But when i try to access my DTML document comes authentication window. I
can't authenticate it in any of my usernames.

Traceback (innermost last): File
/usr/local/Zope-2.2.0/lib/python/ZPublisher/Publish.py, line 222, in
publish_module File /usr/local/Zope-2.2.0/lib/python/ZPublisher/Publish.py,
line 187, in publish File
/usr/local/Zope-2.2.0/lib/python/ZPublisher/Publish.py, line 171, in publish
File /usr/local/Zope-2.2.0/lib/python/ZPublisher/mapply.py, line 160, in
mapply (Object: email_accounts) File
/usr/local/Zope-2.2.0/lib/python/ZPublisher/Publish.py, line 112, in
call_object (Object: email_accounts) File
/usr/local/Zope-2.2.0/lib/python/OFS/DTMLDocument.py, line 170, in __call__
(Object: email_accounts) File
/usr/local/Zope-2.2.0/lib/python/DocumentTemplate/DT_String.py, line 502, in
__call__ (Object: email_accounts) File
/usr/local/Zope-2.2.0/lib/python/DocumentTemplate/DT_Let.py, line 147, in
render (Object: resDTML="Imap('Authentication',REQUEST,1)") File
/usr/local/Zope-2.2.0/lib/python/DocumentTemplate/DT_Util.py, line 337, in
eval (Object: resDTML.cn) (Info: resDTML) File <string>, line 0, in ? File
/usr/local/Zope-2.2.0/lib/python/DocumentTemplate/DT_Util.py, line 142, in
careful_getattr File /usr/local/Zope-2.2.0/lib/python/OFS/DTMLMethod.py,
line 189, in validate (Object: email_accounts) File
/usr/local/Zope-2.2.0/lib/python/AccessControl/SecurityManager.py, line 139,
in validate File
/usr/local/Zope-2.2.0/lib/python/AccessControl/ZopeSecurityPolicy.py, line
159, in validate Unauthorized: cn 
case is that i have login window which passes user information to another
DTML document. User information is different than my zope user.

ex. i log into my Zope management as jarkkov (so that stays at my browsers
cache, until i restart browser)
i type in my login document '666666' and 'password', these values are
submitted to another document called email_accounts, which uses external
method with submitted parametres and return values into email_accounts
document. Above error message is shown. in zope 2.1.6 environment it did'nt

I tied to create all kind of users on users folder and tried to give all
permissions to anonymous user and tried to access anonymously thrue another
browser, but nothing seems to work.

This is essential that i can anonymously access to this DTML documents and
submit any kind of values on my REQUEST.

All the documents are on subfolder called testweb and i noticed that Zope
2.2.0, i have ownership in all documents and folders. testweb is owned
directly by jarkkov (testweb/acl_users) and all documents in that folder. 

I also tried post data to email_accounts thrue browser like this:
on Zope 2.1.6 it worked, but with Zope 2.2.0, ZServer asked authentication.

I can't remove ownership or can i? Is it the blocking my access anonymously
to documents?
What i have to do to make my project work on new Zope version?


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to