Back on Februrary 14th, I submitted this bug, however your account of it
is much better than mine.

It has been pending for quite some time, but either way I never found a
good solution to this problem.  There is some sort of work around
involving continuing to present next buttons with sequence+1 until you
get to the end of the sequence.


> Hi,
> I am working on a project with Zope. Unfortunately I am having a problem 
> whith the <dtml-in > tag. I am using the batch processing feature and want to 
> show only one element per sequence. I do this by setting size=1 and orphan=1. 
> But th <dtml-in> tag only iterates over the first two records (I have 8 
> records). It iterates over all 8 records when I use size=2 orphan=1. I think 
> this is a bug.
> The problem seems to be in the correct value of next-sequence.
> Could someone tell me how I could fix this? Here is my code:
> <dtml-in showAdressData size=1 orphan=1 start=query_start>
>   <dtml-if sequence-start>
>     <dtml-if previous-sequence>
>       <a href="<dtml-var URL><dtml-var sequence-query>query_start=<dtml-var 
> previous-sequence-start-number>">&lt;&lt;</a>
>     <dtml-else>
>       &lt;&lt;
>     </dtml-if previous-sequence>
> [...]
>   </dtml-if sequence-start>
> [...]
>   <dtml-if sequence-end>
>     </table>
>     <dtml-if next-sequence>
>       <a href="<dtml-var URL><dtml-var sequence-query>query_start=<dtml-var 
> next-sequence-start-number>">&gt;&gt;</a>
>     <dtml-else>
>       &gt;&gt;
>     </dtml-if next-sequence>
>   </dtml-if sequence-end>
> </dtml-in>
> -- 
> Marcus Gruendler
> WWW  :

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to