Two other Zopistas reported similar problems. Both succeeded eventually in
getting Xron started, but we didn't succeed in diagnosing the problem, nor
in determining precisely how to work around it. I myself haven't been able
to reproduce the problem.

The problem seems to occur only on Linux, but it does not always occur. Some
users have successfully started Xron on Linux with no problem. The problem
seems to have to do with contention for a lock on ZODB. Did you see any log
or console message that would confirm this?

One user went to the console and killed all the Zope processes that were
running at the time, then restarted Zope from the command line. The second
time, Zope started up correctly with Xron.

Another user thought that he had mistakenly tried to start Zope while logged
in as root. When he restarted as a different user, Zope started up with Xron
correctly. I suspect that the user was not relevant to the Xron problem (it
is normal in some installations to start as root), but that the restarting
was the key.

One user thought that the monitor process contributed to the lock
contention. I don't know, but it might be worthwhile to try to restart Zope
without the monitor (changing the start-up options to disable the monitor).

The problem seems to relate to Xron's creating the Schedule catalog the
first time the Xron product is loaded during Zope start-up. If you succeed
in creating the Schedule one time, the problem will not recurr, as Xron will
just use the existing Schedule.

I hope that helps you get started. Let me know how it goes. I'll copy this
email to the zope list in hopes that someone else can shed some light on the

-- Loren

----- Original Message -----
From: "Nicholas Lo" <[EMAIL PROTECTED]>
Sent: August 18, 2000 12:41 AM
Subject: xcron test

> Hi Loren,
> I have a problem with installing Xron 0.9 onto my machine. Currently,
> I'm running SuSE Linux 6.4 on a 600MHz/128Mb/20Gb PC. I have followed
> the release note and set the STUPID_LOG_FILE environment variable to
> point the log file, and Xron itself is, of course, resides in the
> /Products directory. When I start Zope, the console looks okay. However,
> the browser keeps on loading and loading and could not show the Zope
> management screen. I have also tried Xron on my notebook, which is
> running Win98. Everything works just fine. I just wonder what's gone
> wrong.
> Thanks.
> Nick

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to