I have a directory with a SiteAccess rule in it.  Under that directory,
versions and Zcatalogs no longer seem to work.

This is with  (SiteAccess-2-0-0b3)) and Zope 2.2.0 and 2.2.1b1

When I add a version, I can't start working in it.  Clicking on the button
doesn't seem to do anything.

When I add a Zcatalog and try to find items to it, I get the following
error:

Zope has encountered an error while publishing this resource.

Error Type: IndexError
Error Value: list index out of range


Traceback (innermost last):
  File /usr/local/Zope-2.2.1b1-src/lib/python/ZPublisher/Publish.py, line
222, in publish_module
  File /usr/local/Zope-2.2.1b1-src/lib/python/ZPublisher/Publish.py, line
187, in publish
  File /usr/local/Zope-2.2.1b1-src/lib/python/Zope/__init__.py, line 221, in
zpublisher_exception_hook
    (Object: Traversable)
  File /usr/local/Zope-2.2.1b1-src/lib/python/ZPublisher/Publish.py, line
171, in publish
  File /usr/local/Zope-2.2.1b1-src/lib/python/ZPublisher/mapply.py, line
160, in mapply
    (Object: manage_catalogFoundItems)
  File /usr/local/Zope-2.2.1b1-src/lib/python/ZPublisher/Publish.py, line
112, in call_object
    (Object: manage_catalogFoundItems)
  File /usr/local/Zope-2.2.1b1-src/lib/python/Products/ZCatalog/ZCatalog.py,
line 321, in manage_catalogFoundItems
    (Object: Traversable)
IndexError: (see above)


Can anyone help or suggest a way around this?  I'm assuming it's a problem
with SiteAccess and interaction with Zope 2.2x?

-- 
/chris/


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to