I have a python product which uses a ZCatalog and CatalogAware
products.  The catalog has a number of Field and TextIndex indexes.
Search the ZCatalog has worked fine when my product is instantiated in
2.1.6.  But now when I instantiate my product in 2.2.0 or 2.2.1,
searching only works when I search using a field index.  Searching using
a textindex always results in an empty result, even tho I can see the
words I am searching for in the Vocabulary!  Any suggestions?  I have
tried reindexing, completey recreating the Zcatalog, recreating the
Vobulary and reindexing, and nothing has changed the behaviour.  Are
textindexes simply broken?

ZCatalog seems very volatile to me!  Every time I have upgraded way back
from zope2.1.3, something in zcatalog has changed and boken my product.
So far I have managed to find fixes, but this one has got me baffled!!

Adroit Internet Solutions Pty Ltd (www.adroit.net)
Phone:   +613 9563 4461
Fax:     +613 9563 3856
Mobile:  +61 414 938 124
ICQ:     79303381

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to