Hi Aitor,

(I am posting to the Zope mailing list, too.)

>I have Zope in W2000
>Zope 2.2.1
>Internet Explorer 5.0

Ok. I just tried with Zope on Linux, after I tried with Zope on Windows 98.

  RedHat 6.2
  Zope 2.1.6
  Internet Explorer 5.0

Guess what? The thread did not hang. The long thread returns, but the value 
of your "var" was 2.

The situation is then:

(1) For Zope running on Windows, the long thread hangs and never returns 
anything to the browser.

(2) For Zope running on Linux, the long thread gets into transaction 
conflict. But Zope was smart enough to abort the transaction and restart the 
request again. (Just like what other people said.)

I think this should be considered as a bug in Zope for the Windows platform. 
We should submit the bug report to the Zope bug collector. Notice that it 
happens for Zope 2.1.6 and Zope 2.2.1, I wonder why no one has reported this 
bug... (or has it been reported but not been fixed?)

regards,

Hung Jung


_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to