Hi everyone,

I'm running Zope 2.2.2 on Linux. All of the sudden I've got some DTML
methods that are no longer being acquired in subfolders. I changed the HTML
a bit and the whole thing stopped working! I've got some little navigation
menus that I'd like to reuse in subfolders by simply referring to them via
<dtml-var foo> and having them acquired from the parent folder. Anybody know
when this is happening? Here's a sample of the code and the traceback:

<table width="100%" border=0 cellpadding=1 cellspacing=0 bgcolor="#000000">
  <td width="100%">
   <table width="100%" border=0 cellpadding=2 cellspacing=0
     <td width="100%">
      <font face="Verdana, Arial, Helvetica,
sans-serif" color="004A6D" size=2>
      <font color="#EEEEEE">Quick Links</font>
  <td width="*">
   <table width="100%" border=0 cellpadding=2 cellspacing=0
     <td><font face="Verdana, Arial, Helvetica, sans-serif" size="2">
      <dtml-var lidisc><a href="/Navigation/">Site map</a><br>
      <dtml-var lidisc><a href="/distinfo">District Information</a><br>
      <dtml-var lidisc><a href="/feedback">Site feedback</a><br>
      <dtml-var lidisc><a
href="http://mail.isd197.k12.mn.us/servlet/webacc">E-Mail System</a><br>
      <dtml-var lidisc><a href="/about">About our site</a><br>
      <dtml-if "AUTHENTICATED_USER.has_permission('Edit', this())">
       <dtml-var lidisc><a href="/web-devel/">Web-devel Page</a>

Traceback (innermost last):
  File /var/lib/2.2.0/lib/python/ZPublisher/Publish.py, line 222, in
  File /var/lib/2.2.0/lib/python/ZPublisher/Publish.py, line 187, in publish
  File /var/lib/2.2.0/lib/python/Zope/__init__.py, line 221, in
    (Object: Traversable)
  File /var/lib/2.2.0/lib/python/ZPublisher/Publish.py, line 171, in publish
  File /var/lib/2.2.0/lib/python/ZPublisher/mapply.py, line 160, in mapply
    (Object: local_links)
  File /var/lib/2.2.0/lib/python/ZPublisher/Publish.py, line 112, in
    (Object: local_links)
  File /var/lib/zope/2.2.0/lib/python/OFS/DTMLDocument.py, line 177, in
    (Object: local_links)
  File /var/lib/zope/2.2.0/lib/python/DocumentTemplate/DT_String.py, line
528, in __call__
    (Object: local_links)
AttributeError: (see above)


Any ideas?


Tim Wilson      | Visit Sibley online:         | Check out:
Henry Sibley HS | http://www.isd197.k12.mn.us/ | http://www.zope.org/
W. St. Paul, MN |                              | http://slashdot.org/
[EMAIL PROTECTED] |   <dtml-var pithy_quote>     | http://linux.com/

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to