Hello everybody,
I started to play with Zope in order to use it as intranet platform. For
this I need database access. I tried odbc and MySQL and got it working
fine. However we have some existing warehouse queries which take minutes
to complete. When I set up ZODBC connection and ZSQL method to access
such query, it halts all other Zope activities until it finishes. I
tried this both with NT Zope and Linux Zope, ODBC and MySQL DAs. As long
as the query runs, no other requests are serviced. 
        I understand that long query blocks database connection, but I thought
Zope is threaded, so it should run other requests not using this
database connection just fine, no? Could it be that the python binary
used is not compiled for threading? I spent yesterday afternoon and this
morning looking for solution to this problem on the net, but with no
luck yet.

Can anybody enlighten me why is that? And what can I do to fix this.

Otherwise I like Zope a lot. Easy, featured, just great. 

Thanks in advance and

Best regards,

Petr Hrasky
--------------------------------------------
IT Department
BNP-Dresdner Bank (CR), a.s.
+420-2-57006474



_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to