Thanks to Kapil, Geir and Daniel for their various syntaxes. Very enlightening.

I did cure it but by accident while experimenting with the solutions offered
(so they *were* worth it)

The zclass title is displayed a la slashdot or freshmeat in boxes as clickable
links drawn from the catalog. If (logged in) I selected them then I was always
anonymous. If I manually typed the url/manage then deleted the /manage then I
am recognised. Very odd. So I tried a different way of prompting for login - I
protected a file in the root. Hey presto, now when I login it is fine. Or seem
fine so far. (All syntaxes seem to work, btw)

So, a tip for login/recognition issues would be to try authenticating a
different way, perhaps further up the tree etc.

I had protected the factory and used a link /myfolder/manage_addProduct/blah...
to prompt for authentication. Worked for actually *being* authenticated but not
for being *detected* as such.

Is this a bug?



Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to