doh, I was the one running the odd version - 1.1.3 as opposed to the newer
1.2 - I guess I never updated this when I updated the full zope install.
The new version looks like it would of been much easier to fix, if it had 
the problem in the first place!

-----Original Message-----
From: Jon Franz 
Sent: Monday, October 09, 2000 7:07 PM
To: '[EMAIL PROTECTED]'; Jon Franz
Cc: [EMAIL PROTECTED]
Subject: RE: [Zope] ZMysqlDA error, and a workaround


Wow, that looks very diffrent from my ZMySQLDA, what version are you
running?
I just got mine to work, I had to mod the def section in the db.py and some
of the code in the MySQLmodule.c file - I want to make it available for
download
and whatnot, but I need to look through the setup script (since it generated
the 
.c file, I think, or at least  moded it) and make sure what I did it
integrated
into the source at that stage...

-----Original Message-----
From: Steve Spicklemire [mailto:[EMAIL PROTECTED]]
Sent: Monday, October 09, 2000 7:00 PM
To: [EMAIL PROTECTED]
Cc: [EMAIL PROTECTED]; [EMAIL PROTECTED]
Subject: Re: [Zope] ZMysqlDA error, and a workaround



I'm guessing it's in db.py in ZMySQLDA, I had to do the same
thing with DECMIAL as shown here, I didn't post that since I'm
not sure most folks would want this behavior.... but you should 
be able to do the same with MEDIUMINT:

class DB:

    defs={
        FIELD_TYPE.CHAR: "i", FIELD_TYPE.DATE: "d",
        FIELD_TYPE.DATETIME: "d", FIELD_TYPE.DECIMAL: "n",
        FIELD_TYPE.DOUBLE: "n", FIELD_TYPE.FLOAT: "n", FIELD_TYPE.INT24:
"i",
        FIELD_TYPE.LONG: "i", FIELD_TYPE.LONGLONG: "l",
        FIELD_TYPE.SHORT: "i", FIELD_TYPE.TIMESTAMP: "d",
        FIELD_TYPE.TINY: "i", FIELD_TYPE.YEAR: "i",
        }

    conv={
        FIELD_TYPE.TINY: int,
        FIELD_TYPE.SHORT: int,
        FIELD_TYPE.LONG: int,
        FIELD_TYPE.FLOAT: float,
        FIELD_TYPE.DOUBLE: float,
        FIELD_TYPE.LONGLONG: long,
        FIELD_TYPE.INT24: int,
        FIELD_TYPE.DECIMAL: float,
        FIELD_TYPE.YEAR: int
        }


-steve

>>>>> "Jon" == Jon Franz <[EMAIL PROTECTED]> writes:

    Jon> This is additional info for the error mentioned in my last
    Jon> email.  If I alter the column definitions to use 'int' as
    Jon> opposed to 'mediumint', then everything works fine!  So, its
    Jon> the 'mediumint' type that isnt mapping properly...  where
    Jon> would i fix this?

    Jon> _______________________________________________ Zope maillist
    Jon> - [EMAIL PROTECTED] http://lists.zope.org/mailman/listinfo/zope
    Jon> ** No cross posts or HTML encoding!  ** (Related lists -
    Jon> http://lists.zope.org/mailman/listinfo/zope-announce
    Jon> http://lists.zope.org/mailman/listinfo/zope-dev )

_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to