After installing two new Products (ZCounter the first time,and FSCounter
the next time), I hit the Restart button in the Zope Control Panel. Zope
did not come up. I tried a manual stop/start. The start resulted in this
error message:

> Traceback (innermost last):
>   File "/usr/home/txpn/Zope/", line 554, in ?
>     exec "import "+MODULE in {}
>   File "<string>", line 1, in ?
>   File "/usr/home/txpn/Zope/lib/python/Zope/", line 110, in ?
>     DB=ZODB.FileStorage.FileStorage(Globals.BobobaseName)
>   File "/usr/home/txpn/Zope/lib/python/ZODB/", line 292,
>     r=self._restore_index()
>   File "/usr/home/txpn/Zope/lib/python/ZODB/", line 427,
>     info=p.load()
> cPickle.UnpicklingError: pickle data was truncated

The data.fs.index file was then corrupt. If I renamed it, and tried
another start, Zope would start fine. I did this twice w/ the same

I'm using Zope 2.2.2. 

Stevea on #zope suggested Jim might be interested in this, and that I
should also send it to a Zope mailing list -- since I'm not on Zope Dev
yet, I'm sending it here. I have a copy of the old index files if anyone
needs to see them.


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to