Have you run ldconfig after editting the /etc/ld/so/conf file? Run
ldconfig -v | grep mysqlclient and see if the library appears. If so,
everything is all set.

Also try an ls -l /usr/local/mysql/lib/libmysql*.

Knight
[EMAIL PROTECTED]

On Fri, 13 Oct 2000, Dale Lance wrote:

> Hi,
> I am trying to build ZMySQLDA 1.20
> mysql has been built successfully on RedHat 7.0 and resides in
> /usr/local/mysql
> I have followed the instructions for editing /etc/ld/so/conf adding
> /usr/local/mysql/lib/mysql
> /usr/local/mysql/lib
> /usr/local/mysql
> to it. (just tomake sure)
> yet I still get the following error
> anyone know where mysqlclient is supposed to be?
> 
> Dale
> 
> 
> > gcc -shared  _mysqlmodule.o  -L/usr/local/mysql/lib -lmysqlclient -o
> > _mysqlmodule.so
> > /usr/bin/ld: cannot find -lmysqlclient
> > collect2: ld returned 1 exit status
> > make: *** [_mysqlmodule.so] Error 1
> > Traceback (innermost last):
> >   File "build.py", line 14, in ?
> >     import MySQLdb
> >   File "MySQLdb.py", line 19, in ?
> >     from _mysql import *
> > ImportError: No module named _mysql
> >
> >
> 
> 
> 
> _______________________________________________
> Zope maillist  -  [EMAIL PROTECTED]
> http://lists.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists - 
>  http://lists.zope.org/mailman/listinfo/zope-announce
>  http://lists.zope.org/mailman/listinfo/zope-dev )
> 
> 


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to