I have a working install of Zope 2.2.2. I installed the python module PoPy 
1.4 and then attempted to install the ZPoPyDA 0.7 DB adapter. The ZPoPyDA 
README said to run a configure script but there was none. So I just moved the 
ZPoPyDA directory it created into the lib/python/Products directory in my zope 

Now for the strange part. When I start zope, I get the following:

2000-10-17T20:25:51 ERROR(200) Zope Couldn't import Products.ZPoPyDA
Traceback (innermost last):
  File /zope_home/lib/python/OFS/Application.py, line 397, in import_products
    (Object: string)
  File /zope_home/lib/python/Products/ZPoPyDA/__init__.py, line 32, in ?
  File /zope_home/lib/python/Products/ZPoPyDA/DA.py, line 35, in ?
  File /zope_home/lib/python/Products/ZPoPyDA/PoPy_db.py, line 27, in ?
ImportError: No module named PoPy

ZPoPyDA comes up as a broken product in the Control Panel. So I checked it out 
on my own. I created a file with the following line:

import PoPy

I ran 'python test' and no errors. I added the line:

import bla

And then ran 'python test' again just to be sure and it did die saying no such 
module bla. I even typed 'import PoPy' in the python interactive shell and 
nothing. So outside of zope, python seems to be able to import PoPy, but when 
zope tries to import ZPoPyDA it claims there is no PoPy module.

Any ideas?

Thanks in advance,

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to