>I think we're reaching a point where we'll soon be able to release a
>Python 2.0-compatible Zope source distribution, but you're right in that
>none of the current ones work properly with Python 2.0.
>Xavier Defrang wrote:
>> Hi folks,
>> I've just downloaded Zope source code to rebuild it on a FreeBSD-4.1 box.
>> Is Zope-2.2.2 so tightly coupled to Python-1.5.2 that It doesn't run with
>> Python 2.0...

Yes, Zope needs a cPickle newer than the one in 1.5.2, but the one in
2.0 is newer still.

Remove the reference to cPickle and cStringIO, and everything* will
compile and run ok.

>>I've got a system-wide installation of Python 2.0 and the
>> ./start scripts fails.  I made a local installtion of Python 1.5.2 just to
>> run Zope.  I changed the path the Python interpreter in the start shell
>> script but it looks like Medusa's asyncore.py can't find tjhe FCNTL
>> module...

* for a suitable small definition of 'everything' ;-)

Toby Dickenson

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to