I'm going to take a guess.  It would appear AFAICT that the ZDiscussions
product installed an object which it hung off the root object (the
application object) when it was first imported.  Maybe it was trying to make
some sort of a singleton by doing so, where the singleton was *not* a
Zope-manageable object (and thus it can't be seen or found via ZopeFind).
When the product was deleted, it did not clean up after itself properly
(specifically, it did not delete this singleton).  While I don't completely
understand the relationship between ZDiscussions and DemoPortal in this case
(I *really* don't understand why you couldn't subsequently import DemoPortal
or Wizard), I think if we dug hard enough we'd find at the bottom of it a
problem like this.

The point being that I'd bet we'd find a programming error staring at us in
this sequence of events if we looked hard enough.  Though it's tempting to
call it a "ZODB corruption" problem, if you really get down to the lower
levels, it's likely an application-level problem.

That said, I'll admit that this distinction is really pedantic when your
Zope doesn't work.  :-)  I'm glad you had the gumption to figure it out...

----- Original Message -----
From: "Bill Welch" <[EMAIL PROTECTED]>
To: "Chris McDonough" <[EMAIL PROTECTED]>
Sent: Wednesday, November 08, 2000 4:21 PM
Subject: Re: [Zope] Is data.fs corrupted?

> Here's my evidence. A record (OID 0) in the "Added Globals" transaction
> refers to a record (OID 57) in the "Installed product DemoPortal"
> transaction.
> >From tranalyzer -r
> TID: 33140200A4749F8 @ 69694 obs 1 len 274 (status 'p') By [Zope]
> "Added Globals"
>         OID: 0 len 204
>                 2, 57
> TID: 3374475482BCF4C @ 3697235 obs 2 len 648 (status 'p') By
> [Zope]
> "Installed product DemoPortal"
>         OID: 137f len 456
>                 1377, 43ed, 43f3, 4431
>                 135e, 43f0, 4389, 1568
>                 442e, 1565
>         OID: 57 len 65
>                 137f
> On Wed, 8 Nov 2000, Chris McDonough wrote:
> > Transactions are only tangentially related to this issue (I'm not sure
> > the "Added globals" transaction 'referred to' the "Installed product
> > DemoPortal" transaction in your example, BTW).

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to