From: Andy McKay

>> It might be that fixing one or both of the above would reduce the DTML
>> pain factor quite a bit. Certainly, it's time to do whatever it takes
>> to banish these "-"-named variables, IMHO.

>I agree, changing the "-" to "_" would remove a whole ton of posts on this
>list and mean I could chop a whole bunch of <dtml-let item=sequence-item>.
>really only see negative reasons for a "-".

For once I will send a "me too" to the list. "sequence-item" is a simple and
plain design error. Decapricate it and and let us use "sequence_item" etc.
together with the other for a while and then drop the old form.

It is the single most annoying thing in dtml, and as far as I can see in the
source it should be trivial to give all those sequence-* a sequence_* name

Regards Max M

Max M. W. Rasmussen,    Denmark.   New Media Director
Specialization is for insects.  -  Robert A. Heinlein

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to