>We have had the same problem with "saving" Versions on zope 2.2.2 +
>ZEO. Our ZSS servers are on linux and our Zope Clients are on NT
>(don't ask).

I have all ZSS and ZCS on NT but I isolated the possible zeo's
related problem running my Data.fs on a standalone zope and the problems 

>The only solution that worked for us so far is to repeatedly modify
>the locked object and re-save the version. If it doesn't work at
>first try again after a few hours. Eventually (after a dozen or so
>tries) it seems to sort itself out.
>We haven't seen documents become folders yet, but most of the work
>was done in ZClasses.

I solved the problem with some packs to the Database. In no understandable 
way after one of the packs the discard and save worked
okay. In one of the packs I got this output:

ERROR(200) ZODB FS FS21 ERROR: Bad reference to 
ERROR(200) ZODB FS FS21 ERROR: Bad reference to 

Its obviously there was something wrong with myversion object,
but only after some more packs the save/discard worked okay.

But I quit versions because the locking of a folder when you
add objects is not a good feature of versions, specially if the one
locked is root, means you just loose the possibility of changing your
online "version" of your site like adding new objects, and changing locked 

I know this versionlock happened with CatalogAware objects from experience 
with zope 2.1.6 but for instance the locking of a document even for a change 
out of the version is something never happened in 2.1.6. I'm just seeing 
this in 222, maybe this is a result of those objects being in a locked 

Best Regards,
Júlio Silva
Get more from the Web.  FREE MSN Explorer download : http://explorer.msn.com

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to