[EMAIL PROTECTED] writes:

> I installed 2.2.4b1 over 2.2.3, and everything seems to work fine, but, when
> I IE5.5 to manage my sites, I loose some icons and graphics (not all!).
> But, if I clear my cache, The icons reappears, but only for a while!  Am I
> the only only experiencing this problem?

I found this problem and sent the following patch to the Collector.  

*** ImageFile.py        2000/11/24 05:16:42     1.1
--- ImageFile.py        2000/11/24 05:27:59
***************
*** 137,146 ****
              try:    mod_since=long(DateTime(header).timeTime())
              except: mod_since=None
              if mod_since is not None:
!                 if self._p_mtime:
!                     last_mod = long(self._p_mtime)
!                 else:
!                     last_mod = long(0)
                  if last_mod > 0 and last_mod <= mod_since:
                      RESPONSE.setStatus(304)
                      return ''
--- 137,143 ----
              try:    mod_since=long(DateTime(header).timeTime())
              except: mod_since=None
              if mod_since is not None:
!                 last_mod = long(getattr(self, '_p_mtime', 0))
                  if last_mod > 0 and last_mod <= mod_since:
                      RESPONSE.setStatus(304)
                      return ''


--- Alastair


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to