Hi Lee,

   I'm not sure if this will help.. but I do know that I routinely build
Zope on multiple FreeBSD systems and it has never caused a problem like this.
Did you build your own python, or use a port? What flavor of BSD? I've never
had to edit Makefile.pre.in or do.py on FreeBSD 3.x, or 4.x.


>>>>> "Webmaster" == Webmaster  <[EMAIL PROTECTED]> writes:

    Webmaster> I haven't solved my BSD problem but I did discover that
    Webmaster> there are BSD ports of Zope and Zope products
    Webmaster> maintained at
    Webmaster> http://www.freebsd.org/cgi/ports.cgi?query=zope&stype=all

    Webmaster> I haven't been able to get the port to work yet but I
    Webmaster> suspect that it's because I don't have root access to
    Webmaster> the server.

    Webmaster> That will have to wait till Monday when the *senior*
    Webmaster> tech support guys are on duty. I called my webhost tech
    Webmaster> support last night and I happened to ask which version
    Webmaster> of BSD they used. The 'technician' replied, and I
    Webmaster> quote: "BSD? What does that do? I've never heard of
    Webmaster> it."

    Webmaster> I pointed out that BSD was the version of Unix on all
    Webmaster> his host servers.

    Webmaster> At least he made me feel like less of Unix newbie.

    Webmaster> :)

    Webmaster> Lee Hunter Hum Communications Ltd.

    >> -----Original Message----- From: Lee Hunter
    >> [mailto:[EMAIL PROTECTED]] Sent: November 24, 2000 3:50 PM To:
    >> '[EMAIL PROTECTED]' Subject: BSD 4 installation
    >> I'm trying to build Zope on a BSD server.
    >> According to the install.txt I have to run two commands -
    >> "python w_pcgi.py" and "./start".
    >> I managed to get the first command to run (python w_pcgi.py)
    >> after editing my Makefile.pre.in and do.py as per the FAQ.txt.
    >> But when I when I run the second command (./start) I get the
    >> following error message:
    >> media2: {38} % ./start Traceback (innermost last): File
    >> "/magma/users/u21/wake/zope/z2.py", line 554, in ?  exec
    >> "import "+MODULE in {} File "<string>", line 1, in ?  File
    >> "/magma/users/u21/wake/zope/lib/python/Zope/__init__.py", line
    >> 94, in ?  import ZODB, ZODB.ZApplication, imp File
    >> "/magma/users/u21/wake/zope/lib/python/ZODB/__init__.py", line
    >> 85, in ?  import sys, ExtensionClass, TimeStamp, cPersistence,
    >> Persistence ImportError: No module named ExtensionClass
    >> Any ideas as to what I'm doing wrong?
    >> TIA
    >> Lee Hunter Hum Communications Ltd.

    Webmaster> _______________________________________________ Zope
    Webmaster> maillist - [EMAIL PROTECTED]
    Webmaster> http://lists.zope.org/mailman/listinfo/zope ** No cross
    Webmaster> posts or HTML encoding!  ** (Related lists -
    Webmaster> http://lists.zope.org/mailman/listinfo/zope-announce
    Webmaster> http://lists.zope.org/mailman/listinfo/zope-dev )

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to