michael angelo ruberto writes:
 > one of the DTML methods i've created recently has started to create
 > problems. the method adds properties to documents as people browse zope. it
 > worked fine for a while but now it's causing zope to prompt for a password.
 > i gave the method manager proxy which solved the problem on my test server
 > but didn't make a difference on the intranet zope. the error generated when
 > you click Cancel on the password prompt is "You are not authorized to access
 > manage_addProperties."
It is strange that it worked before you added the manager proxy role:
   "manage_addProperties" is for good reasons protected.

It is strange, too, that the proxy role does not work in the
other installation. Do you use Zope 2.2?
In this case, maybe, something is wrong with the owner
of the method. Moreover, proxy roles are no longer inherited
to called methods.


Dieter

_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to