Mark,

Here's the line from my Zope start script, it may help:

"D:\zope\bin\python.exe" "D:\zope\z2.py" -X -w20080 -f20021 %1 %2 %3 %4 %5
%6 %7 %8 %9

This line turns off 'debugging' mode (note the absence of -D), it also shuts
down all servers by default (-X), then explicitly starts http on port 20080
(-w20080) and ftp on 20021 (-f20021).

You should also look at the docstrings in <zopedir>/z2.py for more options.

hth

Phil
[EMAIL PROTECTED]

----- Original Message -----
From: "Mark A. Pappas" <[EMAIL PROTECTED]>
To: "Zope User Maillist" <[EMAIL PROTECTED]>
Sent: Tuesday, December 05, 2000 9:56 PM
Subject: [Zope] Zope Beginner


> Hi All,
> I'm new to Zope. Just installed it a few minutes ago. Everything installed
> fine. Logged in
>
> http://localhost:8080/manage
>
> worked great. I'm trying to figure out the web server portion of zope. I
was
> reading the docs the chart that talks about ZServer Command Line Switches.
> It tells me the default port is 8080. To change that do a
>
> -w 80
>
> after the -D. In the start.bat. I tried all kinds of things and never was
> able to get zope up on port 80 as a web server (www.whatever.com_ or
> XXX.XXX.XXX.XXX). What am I missing?
>
> Thanks
> Mark A. Pappas
>
>
> Ashecca Communications, Inc.
> 1550 Creighton, Rd.
> Suite 6
> Pensacola, FL 32504
>
> Phone: (850) 474-4027
> Fax: (850) 474-3647
>
>
> _______________________________________________
> Zope maillist  -  [EMAIL PROTECTED]
> http://lists.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
>  http://lists.zope.org/mailman/listinfo/zope-announce
>  http://lists.zope.org/mailman/listinfo/zope-dev )


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to