Here Is some tips to install PoPy DA on a RH6.2

First: You have to use Postgres7.0 with PoPy1.4
- download the Postgres7.0 with the development libraries (the development
RPM from the Postgres download)
- Download the Popy1.4.1 and the ZPopyDA0.7
- untar Popy1.4.1
- $./configure
- change the Makefile ... the include path isn't /usr/include/postgres but
it's /usr/include/pgsql
- the file /usr/include/pgsql/os.h is a broken link .. we have to solve this
download the source distribution of Posrgress7.0 (not the RPM) and
substitute the broken link os.h with the file linux.h ... rename
linux.h->os.h and put it in the correct path (/usr/include/pgsql)
- make will now finish without errors!! and you get the Popymodule.so
- copy the popymodule.so in the [zopedir]/lib/python

- Untar the  ZPopyDA and go to the ZPoPyDa directory in the
lib/python/Products dir of Zope
- modify the PoPy_db.py file changing,

__compatibility__ = ('1.4','1.4.1')

- Launch Zope and All WORKS!!

Hope this Help

Paolo Quaglia
Information Technology Coordinator
Sitek S.p.A.

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to