> Here Is some tips to install PoPy DA on a RH6.2
> First: You have to use Postgres7.0 with PoPy1.4
> - download the Postgres7.0 with the development libraries (the development
> RPM from the Postgres download)
> - Download the Popy1.4.1 and the ZPopyDA0.7
> - untar Popy1.4.1
> - $./configure


        ./configure --postgreql-includes=/usr/include/pgsql

is much better (do a ./configure --help to display all the configuration

> - change the Makefile ... the include path isn't /usr/include/postgres but
> it's /usr/include/pgsql

not required if you do as above.

> - the file /usr/include/pgsql/os.h is a broken link .. we have to solve this
> prob

yes, this is a problem.

> - copy the popymodule.so in the [zopedir]/lib/python

no. popy should live in the *python* hierarchy. just do a "make install"
and make will take care of installing it in the right directory
(usually /usr/lib/python1.5/site-packages or the local alternative.)


Federico Di Gregorio
MIXAD LIVE Chief of Research & Technology              [EMAIL PROTECTED]
Debian GNU/Linux Developer & Italian Press Contact        [EMAIL PROTECTED]
              All programmers are optimists. -- Frederick P. Brooks, Jr.

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to