I have a (regular) folder on root level with ZSQL methods.
I have a transparent folder on root level with a ZMySQLdatabase connection

When i manage any of the ZSQL method, i get that :
Warning: There are no SQL database connections. You need to add a Zope 
SQL database connection before you can use an Zope SQL Method
BUT test tab works fine, and overall, the ZSQL methods called thru DTML are 
still working (it didn't broke my application)

When i put a ZMysqldatabase connection in the folder with ZSQL methods, 
suddently, managing the ZSQLmethod brings all the right informations (but with the 
"new" ZmySQLdatabase connection).

So, as all works fine, except the "edit" tab on ZSQLMethod, I tried to look at the 
"SQLConnectionIDs" to see if i can workaround it but this is (much) over my python 
knowledge so ....
Is it a problem in TP 0.3 or in ZSQL methods ? Any idea ?

I'm on Linux, 2.2.4, siteroot, the 3 latest hotfix, and transparent Folder 0.3
ZMysqlDA 1.2.0

PS : i don't know if the problem was there on TP 0.2 because i didn't touched the 
ZSQL methods for a while (before reorganizing with the Tranparent Folder, which is a 
great great great (tm) product.

Didier Georgieff
DDAF du Bas-Rhin - Cellule SIG 
2, rue des Mineurs 67070 Strasbourg Cedex
tél : - fax :
SIT du Bas-Rhin : http://www.bas-rhin.sit.gouv.fr
GéoWeb http://sertit10.u-strasbg.fr

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to