Merry Xmas everybody !
I'm trying to get zope to work on an SGI, Irix 5.3.
Python isn't available, so I have to compile it my own
being a normal user, not root, with quota and all...
anyway.

I compile Python (1.5.2), in my home dir with threads and all
(as I've read in tyhe how-to's). Then I untar zope (2.2.4)
run the -wo_pcgi (I'll be working with ZServer only, so
it should be fine), set the superuser password and make
the ./start script as follows:

reldir=`dirname $0`
PYTHONHOME=`cd $reldir; pwd`
export PYTHONHOME
exec /path-to-my-python-installation/bin/python \
     $PYTHONHOME/z2.py \
     -w 8000 "$@"

Then go to my zope dir and ./start... but it doesn't work :-(
That's what I get:

Traceback (innermost last):
  File "/my-home-dir/zope/z2.py", line 554, in ?
    exec "import "+MODULE in {}
  File "<string>", line 1, in ?
  File "/my-home-dir/zope/lib/python/Zope/__init__.py", line 94, in ?
    import ZODB, ZODB.ZApplication, imp
  File "/my-home-dir/zope/lib/python/ZODB/__init__.py", line 85, in ?
    import sys, ExtensionClass, TimeStamp, cPersistence, Persistence
ImportError: No module named ExtensionClass

Is it something I've missed when I compiled python ? Or a specific
irix issue ? or something else ?

Have the best of times,
Dimitris


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to