I get back exactly nothing, no 'Not Found', no classes/attributes. I
believe that I've installed correctly. When I ask for a product that
doesn't exist, I get a traceback that starts in Extensions/zclassInfo.py.

I've tried in on Membership, LoginManager, ZPatterns, Poll, Etailer, and
zCommerce. Zope 2.2.2, linux.


On Sat, 6 Jan 2001, Philipp Auersperg wrote:

> ZclassReverse consists of two parts, the client part in ObjectDomain
> and the server part that extracts the class infos on the Zope side.
> That means that the methods provided in the zclassReverse folder
> expose internals of your ZClasses, they DONT BREAK ANYTHING in your
> Zope since the methods exposed in the zclassReverse folder just are
> read-only.
> the 'invalid syntax' error orrurs if something goes wrong when you call the server 
> you can check that manually if you type the following url into your
> browser (fill in your server,port and product):
> http://yourserver:8080/zclassInfo/getClassInfos?product=QSurvey
> When you get a collection of classes and yttriutes it works, in your
> case Zope returns it's 'Not found' screen.
> Solution:
> check if you have installed the server part of ZClassReverse which consists of:
> 1. zclassInfo.py that has to be copied into your Extensions folder
> 2. import zclassInfo.zexp into your Zope root folder
> When that works you should be able to reverse your product, let me
> hear if it worked for you
> thanls and good luck
> phil
> ---------- Original Message ----------------------------------
> From: Bill Welch <[EMAIL PROTECTED]>
> Date: Fri, 5 Jan 2001 11:47:29 -0500
> >in the moment dont install ZClassReverse on production machines since for now 
> >the client module comunicates unauthorized to Zope, but I will be working on 
> >it as I'll have time.
> >
> >Does this mean it breaks something or that it won't work? Is this the source 
> >of my 'invalid syntax' error?
> >
> >Bill.
> >

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to