Hello all,

I have a problem which i suspect is site root's problem.

The scenario, I have folders F1, F1a and F2, where F1a is a child of F1
and F2 is on the same directory level as F1. Also F1 and F2 have their
own DB-connections DB1 and DB2 respectively, which have the exact same


1) i placed a SiteRoot in F1, 
2) then removed it,
3) copied & pasted F1a into F2,
4) renamed the F1a in F2 to F2a,
5) create a SiteRoot in F1 again,
6) and create a SiteRoot in F2

i've also tried restarting Zope between steps 2 and 3

Then it seems that the ZSQL Methods in F2a are referring still referring
to the MySQL DB connection in F1. I've tested it many tiems with otehr
folders aswell, and it seems that they're all reacting the same way. 

In other words, it seems like once a SiteRoot has been created in the
folder, the DB connections stick to it. I've also tried the "Undo" from
Zope's Management Interface, but to no avail.

Perhaps my intuition of all this is wrong altogether. 

Anyone out there experienced the same problem, or have any solutions to
this problem?

Thanks Zopistas,

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to