After following several howtos, tracking numerous threads from this list,
and spending several days losing my mind, I sense that I am finally getting
closer to having Zope and MySQL talking to each other.

I am running on Linux with Redhat with MySQL 3.22.32 and ZMySQLDA with
ZMySQL-python.  The later two are installed such that ZMySQLDA is NOT
broken. I installed using the RPMs supplied by Ron Bickers available on his
FTP site (thanks, Ron) and followed additional instructions supplied on
earlier threads.

My problem now is I can't find a connection string that works. I understand
the connection syntax and tried every possibility. My suspicion is that I
am having a permissions problem with MySQL. I found this former list email:

>> My suggestion would be to set up mysql to accept a null login (no
>> username, no password), create a database in there called "test" and
>> connect with the connection string "test@localhost"

>thank u, this was the point to my problem. I have tried a nologin mysql
and it
>worked with database@myhost !!! :)
>so i know i have a grant table problem in mysql (no big deal - i hope :) )

Being a relative newbie to this whole thing (Linux, Zope, MySQL, etc.), how
do I create a null login in MySQL with blanket privleges? Could it still be
a faulty ZMySQLDA setup? How do I troubleshoot that possibility?


P. Johnson

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to