I've been using 2.1.6 for a long time without any problem, using a home
compiled python 1.5.2

Yesterday I've tried to upgrade to 2.3.0a1 the following way:

export each and every home made sites and products (ZClasses) from 2.1.6
stop 2.1.6
install 2.3.0a1 and start it
import each and every exported sites and products

(I've not tried using the same Data.fs as 2.1.6)

In all instances of a ZClass I've made, I used to (in 2.1.6) call a DTML
method from my browser which was protected in a way to display the
authentication box, allowing me to enter my username and password.

The username and password should give me a role created in the ZClass
instance constructor, this role is allowed to create and modify some
subobjects (another ZClass)

Since I've installed 2.3.0a1 then when I tell my browser to "call" the
DTML method the authentication box appears but I'm not able to
authenticate myself: it always give me an unauthorized exception.

Looking at zope log it gives me a 401 error on the DTML method.

If I modify this method to do nothing but return plain text the problem

I've checked several times the username and password and I'm sure I've
typed them correctly.

In one instance of my ZClass I've tried to give all permissions to the
created role, but with no luck.

I've finally stopped 2.3.0a1 and relaunched the 2.1.6.
Does someone have any idea of where the problem may come from ?
Should I try to use the same Data.fs of 2.1.6 ?
Should I try to use 2.2.5 instead of 2.3.0a1 (I'd like to be able to use
PythonScripts) ?

Thanks in advance.

Jerome ALET - [EMAIL PROTECTED] - http://cortex.unice.fr/~jerome
Fac de Medecine de Nice        http://wwwmed.unice.fr 
Tel: (+33) 4 93 37 76 30     Fax: (+33) 4 93 53 15 15
28 Avenue de Valombrose - 06107 NICE Cedex 2 - FRANCE

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to