Hi,

Since a few days I'm experiencing some response problems on my zope site. At
some moments calling a page goes very fast a few seconds later, recalling
this page takes very long! At the end, every page takes long time, if they
ever appear....

If I use a simple memory checker program, then I see that memory leaks
away.... (memory goes from 48Mfree to 41M in 15min!! and eventially it ends
at a few thousands K)  However, I've no idea if it is comming from Zope
2.2.5 or from my database adapter in zope, or from somewhere else....
Is there a good way to check memory leaks and to pinpoint them?

If I ask to show me the processes on my Linux box, I see the following
related ones :

/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (root)

/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (nobody)
/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (nobody)
/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (nobody)
/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (nobody)
/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (nobody)
/usr/local/zope/bin/python /usr/local/zope/z2.py -Z
/home/httpd/zope/var/zProcess.pid (nobody)

gds_inet_server # Interbase Database Remote Server (root)
gds_inet_server # Interbase Database Remote Server (root)

Is it normal that zope opens so much processes?

Thanks in advance,

Tom.


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to