I have been playing around with Drew's photo product and it works 
great with GIFs but when I try to upload a JPEG into it I get the 

Error Type: IOError
Error Value: decoder jpeg not available

Traceback (innermost last):
   File /usr/local/zope/lib/python/ZPublisher/Publish.py, line 222, in 
   File /usr/local/zope/lib/python/ZPublisher/Publish.py, line 187, in publish
   File /usr/local/zope/lib/python/Zope/__init__.py, line 221, in 
   File /usr/local/zope/lib/python/ZPublisher/Publish.py, line 171, in publish
   File /usr/local/zope/lib/python/ZPublisher/mapply.py, line 160, in mapply
     (Object: manage_addPhoto)
   File /usr/local/zope/lib/python/ZPublisher/Publish.py, line 112, in 
     (Object: manage_addPhoto)
   File /usr/local/zope/lib/python/Products/Photo/Photo.py, line 132, 
in manage_addPhoto
     (Object: Traversable)
   File /usr/local/zope/lib/python/OFS/Image.py, line 276, in manage_upload
     (Object: BZ_li_13.jpg)
   File /usr/local/zope/lib/python/Products/Photo/Photo.py, line 290, 
in update_data
     (Object: BZ_li_13.jpg)
   File /usr/local/zope/lib/python/Products/Photo/Photo.py, line 319, 
in _generateDisplays
     (Object: BZ_li_13.jpg)
   File /usr/local/zope/lib/python/Products/Photo/Photo.py, line 329, 
in _generateDisplay
     (Object: BZ_li_13.jpg)
   File /usr/local/zope/lib/python/Products/Photo/Photo.py, line 370, in resize
     (Object: BZ_li_13.jpg)
   File /usr/local/zope/lib/python1.5/PIL/Image.py, line 634, in resize
   File /usr/local/zope/lib/python1.5/PIL/ImageFile.py, line 133, in load
   File /usr/local/zope/lib/python1.5/PIL/Image.py, line 237, in _getdecoder
IOError: (see above)

I have tried and tried again to recompile jpeg, include the path.. 
whatever! I am using Zope 2.2.4 , on RH 6.2


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to